Kategorien
Allgemein

Fever° und OpenID

Der Neustart hier bedeutete auch einige Anpassungen. Dank eines hervorragendes Wikis der ubernauten und ein wenig Basiswissen im Umgang mit dem Terminal ging es aber alles ganz gut über die Bühne.

Als Dienste habe ich aktuell Fever° und eine OpenID Instanz laufen.


Fever°

fever-fluid

Der Umzug von der alten Domain lief eigentlich ganz gut. MySQL DB exportiert, in die neue Datenbank importiert und dann die Dateien von feedafever.com auf den Server geladen und entpackt.

Die alte Instanz gelöscht und auf http://feedafever.com die Lizenz auf die neue Domain transferriert.

Im Anschluss Fever auf der neuen Domain gestartet (xyz.domain.tld/boot.php), die neuen Daten für die Datenbank und den Authentifizierungscode eingetragen,

fertig.


OpenID
… aber zuerst: let’s encrypt

Um OpenID über eine gesicherte Verbindung aufzurufen, brauchen wir zuerst ein Zertifikat für die eigene Domain. Von Haus aus ist bei den ubernauten nur interne Name (irgendwas.libra.uberspace.de) mit einem Zertifikat abgedeckt. Für die eigene Domain greift man zum Beispiel auf let’s encrypt zurück. Ich ignoriere hier, dass es durchaus kritische Stimmen dazu  gibt, finde die Initiative, freie Zertifikate nutzen zu können, aber an sich sehr gut und lobenswert.

Hintergrund:
https://blog.uberspace.de/lets-encrypt-rollt-an/

Anleitung:
https://wiki.uberspace.de/webserver:https#nutzung_von_let_s-encrypt-zertifikaten

Um die Cent-OS Version des uberspaces zu erfahren (geht alles erst ab CentOS-6), übers Terminal einloggen (am Besten mit SSH Key :)) und das hier eintippen:

cat /etc/redhat-release

Vor dem Konfigurieren von let’s encrypt am Besten bereits die subdomain für den OpenID Dienst anlegen, damit die Zertifikate dafür direkt mit erstellt werden. Achja: Und die subdomain – sofern man keine *wildcard für seine Domain erstellt hat – auch noch richtig verbinden.

Wenn let’s encrypt läuft, gehts mit der OpenID weiter.

OpenID

Anleitung:
https://marvindickhaus.de/2014/04/simpleid-openid-auf-deinem-uberspace/

openid_big_logo_textBei mir lief es nicht auf Anhieb… Ich wollte eigentlich alles in einem Verzeichnis unter der Subdomain installieren – was aber nicht ohne Weiteres ging. Muss auch nicht sein.
Aber auch streng nach der obigen (oder nach dieser)  Anleitung wollte es nicht so richtig. Das roch danach, ein frustiger Ausflug in die Welten der OpenID zu werden…

Am Ende war es die .htaccess Datei, die zu viel an den URLs manipuliert hat. Als ich dann irgendwann  # RewriteBase / nicht mehr auskommentiert habe, sondern es gelassen habe,  wie es in der Vorlage steht, lief es.